summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-02-13 15:10:33 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2022-02-14 10:09:11 +0100
commitecaada08ea555310c3d7c3aef868cbb42c25a62d (patch)
treedb293f5672f7a19b26239f30adaadfb503088958
parent2c9f1c438993999b24a156a26571dd7c56efa4e1 (diff)
downloadguix-patches-ecaada08ea555310c3d7c3aef868cbb42c25a62d.tar
guix-patches-ecaada08ea555310c3d7c3aef868cbb42c25a62d.tar.gz
gnu: Add cl-wordnet.
* gnu/packages/lisp-xyz.scm (cl-wordnet, ecl-wordnet, sbcl-wordnet): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ab85c05bc9..dc0ee27676 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20509,6 +20509,39 @@ identified uniquely.
(define-public ecl-nhooks
(sbcl-package->ecl-package sbcl-nhooks))
+(define-public sbcl-wordnet
+ (let ((commit "8cd0db8f5e84e7a930fa74e590ecddf75cd8e5d6")
+ (revision "0"))
+ (package
+ (name "sbcl-wordnet")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phoe/wordnet")
+ (commit commit)))
+ (sha256
+ (base32 "07p60k295fsfcp0gmkqhrxd68hb38aqva8f4k8xk8bqqxxf42vkq"))
+ (file-name (git-file-name "cl-wordnet" commit))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #f)) ; There are no tests.
+ (inputs
+ (list sbcl-split-sequence))
+ (home-page "https://github.com/phoe/wordnet")
+ (synopsis "Common Lisp interface to WordNet")
+ (description
+ "This software provides an interface by which Common Lisp programs can
+access lexicographic data from WordNet.")
+ (license license:expat))))
+
+(define-public cl-wordnet
+ (sbcl-package->cl-source-package sbcl-wordnet))
+
+(define-public ecl-wordnet
+ (sbcl-package->ecl-package sbcl-wordnet))
+
(define-public sbcl-nfiles
(package
(name "sbcl-nfiles")