summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-09-04 11:41:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-09-14 09:04:36 +0200
commitdceb7b0c3c35fe7cdcb2f8b9116ad047f7affad4 (patch)
treed0c1e2a073ea6905b016e6904ddae3bfd5c58ae2
parentfe98dfe439b60798ffa2127f02554787a2bbe87e (diff)
downloadguix-patches-dceb7b0c3c35fe7cdcb2f8b9116ad047f7affad4.tar
guix-patches-dceb7b0c3c35fe7cdcb2f8b9116ad047f7affad4.tar.gz
gnu: notmuch: Make cross-compilable.
* gnu/packages/mail.scm (notmuch)[arguments]<#:phases>: Use 'cc-for-target' instead of 'gcc'. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/mail.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index ed56338218..43de6e1354 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1378,7 +1378,7 @@ invoking @command{notifymuch} from the post-new hook.")
(("/bin/sh") (which "sh")))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
- (setenv "CC" "gcc")
+ (setenv "CC" ,(cc-for-target))
(setenv "CONFIG_SHELL" (which "sh"))
(let* ((out (assoc-ref outputs "out"))
@@ -1395,7 +1395,7 @@ invoking @command{notifymuch} from the post-new hook.")
(("\\$NOTMUCH_GMIME_X509_CERT_VALIDITY") "0"))))
(add-before 'check 'prepare-test-environment
(lambda _
- (setenv "TEST_CC" "gcc")
+ (setenv "TEST_CC" ,(cc-for-target))
;; Patch various inline shell invocations.
(substitute* (find-files "test" "\\.sh$")
(("/bin/sh") (which "sh")))))