summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-05-24 17:49:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-24 17:49:32 +0200
commita1b802454a6dd9178e9cb0c061d9050bb4d92e78 (patch)
tree4b8a722fec105a4a1c9bcfff0cf63ce09872088c
parent26bcd2a2b2a2d44e71750159486bfd3b0d8230ad (diff)
downloadguix-patches-a1b802454a6dd9178e9cb0c061d9050bb4d92e78.tar
guix-patches-a1b802454a6dd9178e9cb0c061d9050bb4d92e78.tar.gz
gnu: Add fastp.
* gnu/packages/bioinformatics.scm (fastp): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1315127343..3168291f48 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3450,6 +3450,42 @@ The main functions of FastQC are:
@end itemize\n")
(license license:gpl3+)))
+(define-public fastp
+ (package
+ (name "fastp")
+ (version "0.14.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenGene/fastp.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r6ms5zbf5rps4rgp4z73nczadl00b5rqylw8f684isfz27dp0xh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; there are none
+ #:make-flags
+ (list (string-append "BINDIR=" (assoc-ref %outputs "out") "/bin"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'create-target-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p (string-append (assoc-ref outputs "out") "/bin"))
+ #t)))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://github.com/OpenGene/fastp/")
+ (synopsis "All-in-one FastQ preprocessor")
+ (description
+ "Fastp is a tool designed to provide fast all-in-one preprocessing for
+FastQ files. This tool has multi-threading support to afford high
+performance.")
+ (license license:expat)))
+
(define-public htslib
(package
(name "htslib")