summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-14 12:00:08 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-14 12:07:34 +0100
commit72dd5c8766601832ad34bb60bab0b157748f21c4 (patch)
tree15cdeadf512519e2f04beee18c9451c5e45ecf6c
parentd00b6dd689641d960798269536290d5d2b683a55 (diff)
downloadguix-patches-72dd5c8766601832ad34bb60bab0b157748f21c4.tar
guix-patches-72dd5c8766601832ad34bb60bab0b157748f21c4.tar.gz
gnu: xournalpp: Use G-expressions.
* gnu/packages/pdf.scm (xournalpp)[arguments]: Use G-expressions. <#:phases>: Replace WHICH with SEARCH-INPUT-FILES.
-rw-r--r--gnu/packages/pdf.scm32
1 files changed, 18 insertions, 14 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 66c0867d48..724d545283 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -42,6 +42,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
@@ -896,23 +897,26 @@ using a stylus.")
(base32 "16pf50x1ps8dcynnvw5lz7ggl0jg7qvzv6gkd30xg3hkcxff8ch3"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags (list "-DENABLE_CPPUNIT=ON") ;enable tests
- #:imported-modules ((guix build glib-or-gtk-build-system)
+ (list
+ #:configure-flags #~(list "-DENABLE_CPPUNIT=ON") ;enable tests
+ #:imported-modules `((guix build glib-or-gtk-build-system)
,@%cmake-build-system-modules)
- #:modules (((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ #:modules '(((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
(guix build cmake-build-system)
(guix build utils))
- #:phases
- (modify-phases %standard-phases
- ;; Fix path to addr2line utility, which the crash reporter uses.
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/util/Stacktrace.cpp"
- ;; Match only the commandline.
- (("\"addr2line ")
- (string-append "\"" (which "addr2line") " ")))))
- (add-after 'install 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Fix path to addr2line utility, which the crash reporter uses.
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/util/Stacktrace.cpp"
+ ;; Match only the commandline.
+ (("\"addr2line ")
+ (string-append "\""
+ (search-input-file inputs "/bin/addr2line")
+ " ")))))
+ (add-after 'install 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
(list cppunit gettext-minimal help2man pkg-config))
(inputs