summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-26 23:53:11 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-26 15:48:18 +0200
commit62d6da68d0fc238a949650d6fffaec5895495695 (patch)
tree3f43af1eb09c3401d1ab0c84197cbac5cb1c133a
parentaabea838748bd88008988062f8a9751c33d954e4 (diff)
downloadguix-patches-62d6da68d0fc238a949650d6fffaec5895495695.tar
guix-patches-62d6da68d0fc238a949650d6fffaec5895495695.tar.gz
gnu: muse-sequencer: Add optional dependencies.
* gnu/packages/music.scm (muse-sequencer)[native-inputs]: Add perl, python. [inputs]: Add glib, libinstpatch. Sort alphabetically. [arguments]: Remove "-DENABLE_INSTPATCH=OFF" from #:configure-flags. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/music.scm27
1 files changed, 15 insertions, 12 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b38566450a..6aa368fa82 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4784,8 +4784,7 @@ sample library.")
(arguments
`(#:tests? #f ; there is no test target
#:configure-flags
- (list "-DENABLE_INSTPATCH=OFF" ; FIXME: not packaged
- "-DENABLE_VST_NATIVE=OFF"
+ (list "-DENABLE_VST_NATIVE=OFF"
(string-append "-DCMAKE_EXE_LINKER_FLAGS="
"-Wl,-rpath="
(assoc-ref %outputs "out") "/lib/muse-"
@@ -4805,26 +4804,30 @@ sample library.")
#t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
- ("lash" ,lash)
- ("jack" ,jack-1)
- ("liblo" ,liblo)
("dssi" ,dssi)
+ ("fluidsynth" ,fluidsynth)
+ ("glib" ,glib)
+ ("jack" ,jack-1)
("ladspa" ,ladspa)
- ("lv2" ,lv2)
- ("lilv" ,lilv)
- ("sord" ,sord)
- ("libsndfile" ,libsndfile)
+ ("lash" ,lash)
+ ("libinstpatch" ,libinstpatch)
+ ("liblo" ,liblo)
("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("lilv" ,lilv)
("lrdf" ,lrdf)
- ("fluidsynth" ,fluidsynth)
+ ("lv2" ,lv2)
("pcre" ,pcre)
("pulseaudio" ,pulseaudio) ; required by rtaudio
("qtbase" ,qtbase)
("qtsvg" ,qtsvg)
("rtaudio" ,rtaudio)
- ("rubberband" ,rubberband)))
+ ("rubberband" ,rubberband)
+ ("sord" ,sord)))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
("qttools" ,qttools)))
(home-page "https://muse-sequencer.github.io/")
(synopsis "MIDI/Audio sequencer")