summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-14 23:32:14 +0100
committerMarius Bakke <marius@gnu.org>2022-02-15 00:21:15 +0100
commit5e244cd712220b849538b37968226b117e138567 (patch)
treed8976669faf12a4618a2829ff1620c33d103984c
parentaae5efb6d4f02f3f7007d83bdfc656de2cc55622 (diff)
downloadguix-patches-5e244cd712220b849538b37968226b117e138567.tar
guix-patches-5e244cd712220b849538b37968226b117e138567.tar.gz
gnu: python-drmaa: Fix build failure.
* gnu/packages/python-xyz.scm (python-drmaa)[arguments]: Disable sanity checks.
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 00b4e2980a..c67fd6ce71 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7792,7 +7792,12 @@ etc. The core of this module is a decorator factory.")
;; The test suite requires libdrmaa which is provided by the cluster
;; environment. At runtime the environment variable DRMAA_LIBRARY_PATH
;; should be set to the path of the libdrmaa library.
- (arguments '(#:tests? #f))
+ (arguments
+ '(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ ;; Loading the library fails because DRMAA_LIBRARY_PATH
+ ;; is not configured.
+ (delete 'sanity-check))))
(native-inputs
(list python-nose))
(home-page "https://pypi.org/project/drmaa/")