summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 16:07:17 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 16:07:17 +0200
commit4e9bb49688f30724e0459df0457bcdfd783b9b64 (patch)
treeabc51f1b5e432b8bcf4302d126243570bca73458
parent2aa622ca7d82f9093e3dd3b766bbebffa96e904a (diff)
downloadguix-patches-4e9bb49688f30724e0459df0457bcdfd783b9b64.tar
guix-patches-4e9bb49688f30724e0459df0457bcdfd783b9b64.tar.gz
gnu: Add r-structuralvariantannotation.
* gnu/packages/bioconductor.scm (r-structuralvariantannotation): New variable.
-rw-r--r--gnu/packages/bioconductor.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 596e80a9f9..8ec7a6d90d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2600,6 +2600,36 @@ purposes. The package also contains legacy support for early single-end,
ungapped alignment formats.")
(license license:artistic2.0)))
+(define-public r-structuralvariantannotation
+ (package
+ (name "r-structuralvariantannotation")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "StructuralVariantAnnotation" version))
+ (sha256
+ (base32
+ "0ff40703iyf5wk77hbqhphfxnzc2wcshnjhvh66c5l0jvj9z8xvc"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-biostrings" ,r-biostrings)
+ ("r-dplyr" ,r-dplyr)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-stringr" ,r-stringr)
+ ("r-assertthat" ,r-assertthat)
+ ("r-variantannotation" ,r-variantannotation)))
+ (home-page "https://bioconductor.org/packages/StructuralVariantAnnotation/")
+ (synopsis "R package designed to simplify structural variant analysis")
+ (description
+ "This package contains useful helper functions for dealing with structural
+variants in VCF format. The packages contains functions for parsing VCFs from
+a number of popular callers as well as functions for dealing with breakpoints
+involving two separate genomic loci encoded as GRanges objects.")
+ (license license:gpl3)))
+
(define-public r-summarizedexperiment
(package
(name "r-summarizedexperiment")