summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJai Vetrivelan <jaivetrivelan@gmail.com>2022-02-13 20:47:46 +0530
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-14 10:57:45 +0100
commit066cdbfa92698eb19e2f9437e8833e67929b7a21 (patch)
tree3f4a121a6710402d8926ff8127c5efb4d5a11ba0
parent8487383030bad4f85ab28b6153a455f0588e7804 (diff)
downloadguix-patches-066cdbfa92698eb19e2f9437e8833e67929b7a21.tar
guix-patches-066cdbfa92698eb19e2f9437e8833e67929b7a21.tar.gz
gnu: feh: Update to 3.8.
* gnu/packages/image-viewers.scm (feh): Update to 3.8. [inputs]: Sort lexically. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/image-viewers.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 6f8889e3a0..6c5d70032d 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -257,7 +257,7 @@ YouTube videos without requiring API and opens/downloads them using mpv/ytdl.")
(define-public feh
(package
(name "feh")
- (version "3.7.2")
+ (version "3.8")
(home-page "https://feh.finalrewind.org/")
(source (origin
(method url-fetch)
@@ -265,7 +265,7 @@ YouTube videos without requiring API and opens/downloads them using mpv/ytdl.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "0n42kj18ldlcmrmk5qir9gs9irdl1vz9913n8p941x8cfb98ywc4"))))
+ "1a9bsq5j9sl2drzkab0hdhnamalpaszw9mz2prz6scrr5dak8g3z"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases (delete 'configure))
@@ -277,13 +277,13 @@ YouTube videos without requiring API and opens/downloads them using mpv/ytdl.")
"inotify=1")))
(native-inputs
(list perl perl-test-command))
- (inputs (list imlib2
- curl
+ (inputs (list curl
+ imlib2
libexif
libpng
- libxt
libx11
- libxinerama))
+ libxinerama
+ libxt))
(native-search-paths
;; Feh allows overriding the libcurl builtin CA path (unset in Guix)
;; with the same variable as the `curl` command line HTTP tool.