summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart via Guix-patches via <guix-patches@gnu.org>2021-11-28 10:08:56 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-01 17:13:41 +0100
commite7ead4238350e596791d8f335aa76b79d513b425 (patch)
tree98d44a7cc9ff456377a23dcc5f750d8924a4937e
parent7907ddbc3af325c16ea40877d7e15aef00325a0d (diff)
downloadguix-patches-e7ead4238350e596791d8f335aa76b79d513b425.tar
guix-patches-e7ead4238350e596791d8f335aa76b79d513b425.tar.gz
gnu: python-language-server: Add deprecated alias.
* gnu/packages/python-xyz.scm (python-language-server): New variable. Add deprecated alias for package removed in the parent commit. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index afd875212c..3f4396f174 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5073,6 +5073,9 @@ This tool is used in text editing environments to provide a complete
and integrated feature-set for programming Python effectively.")
(license license:expat)))
+(define-public python-language-server
+ (deprecated-package "python-language-server" python-lsp-server))
+
(define-public python-pathspec
(package
(name "python-pathspec")