summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-30 20:49:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-30 20:49:10 +0100
commit3b74b4149851bf5e4fb1a0541acccd8f49df5da8 (patch)
treed4db1e927d6929f61c7bc3c5705ae939ee0c879f
parent1a139682107582e663adf38ae217fc0029b10888 (diff)
downloadguix-patches-3b74b4149851bf5e4fb1a0541acccd8f49df5da8.tar
guix-patches-3b74b4149851bf5e4fb1a0541acccd8f49df5da8.tar.gz
gnu: Add python-polling2.
* gnu/packages/python-xyz.scm (python-polling2): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ffd39860d8..9d202bf65e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2961,6 +2961,28 @@ existing ones.")
;; Tests don't work with python2.
#:tests? #f)))))
+(define-public python-polling2
+ (package
+ (name "python-polling2")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "polling2" version))
+ (sha256
+ (base32 "0hp3238fv6k1qk43gv4jwnv1mwlkmx33akbj560b9nvsry1dmdwh"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #false)) ; no tests included
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/ddmee/polling2")
+ (synopsis "Polling utility with many configurable options")
+ (description "Polling2 is a utility used to wait for a function to return
+a certain expected condition.")
+ (license license:expat)))
+
(define-public python-poyo
(package
(name "python-poyo")