summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-01 13:16:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-01 13:58:04 +0200
commit1e8ad167f6b35da7faffa5b29079d627ac159165 (patch)
tree59fcd789c0ec80ab0327b95967443f4bdb7df5c8
parenta8d62aea2240d5651c857c1145720b4e2cf275ed (diff)
downloadguix-patches-1e8ad167f6b35da7faffa5b29079d627ac159165.tar
guix-patches-1e8ad167f6b35da7faffa5b29079d627ac159165.tar.gz
gnu: python-dotenv: Run test suite.
* gnu/packages/python-xyz.scm (python-dotenv)[arguments]: Add custom 'check phase.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bbe5aed40e..186749b96e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27636,6 +27636,18 @@ systems in Python.")
(sha256
(base32 "0pv5ygpr6syc6zkw21in4ysqs3k7qaxk9m1g5pzlafwm3silkpm5"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (setenv "PATH" (string-append (getenv "PATH") ":"
+ (assoc-ref outputs "out") "/bin"))
+ ;; Skip the ipython tests.
+ (delete-file "tests/test_ipython.py")
+ (invoke "python" "-m" "pytest")))))))
(propagated-inputs
`(("python-click" ,python-click)))
(native-inputs