summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-05 14:55:56 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:15 +0200
commit6b05cfb4e47c28d3432d01d58ae4157d816d9d67 (patch)
tree1f22aeb9fefb0a03b9f83085e49b83bf8f2e9510
parentbef2ee1c588ad6f207f84e1a43e2ade2c4839bce (diff)
downloadguix-patches-6b05cfb4e47c28d3432d01d58ae4157d816d9d67.tar
guix-patches-6b05cfb4e47c28d3432d01d58ae4157d816d9d67.tar.gz
gnu: ghc-integer-logarithms: Replace "--allow-newer" flag.
* gnu/packages/haskell.scm (ghc-integer-logarithms)[arguments]: Replace "--allow-newer" configure flag with a phase that patches the Cabal file.
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5875e9b02e..9dbeae194c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5227,7 +5227,13 @@ occurrences of a substring (the first in case of overlaps) with another.")
"1wj8kgjg5bn2yrs4zh9qfjv85cx6w998j9pi39yrbv305944mb9j"))))
(build-system haskell-build-system)
(arguments
- `(#:configure-flags (list "--allow-newer=tasty")))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'update-constraints
+ (lambda _
+ (substitute* "integer-logarithms.cabal"
+ (("tasty >= 0\\.10 && < 1\\.1")
+ "tasty >= 0.10 && < 1.2")))))))
(native-inputs
`(("ghc-quickcheck" ,ghc-quickcheck)
("ghc-smallcheck" ,ghc-smallcheck)