summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-17 16:21:38 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-17 16:30:00 +0100
commit3822003082478fb3d24af1b411ffe17406a83e93 (patch)
treeccc732541f3ed0eb71783fc4a2b582f95a13c234
parente6c46ec42ea6e986b1030a145cb391235b689735 (diff)
downloadguix-patches-3822003082478fb3d24af1b411ffe17406a83e93.tar
guix-patches-3822003082478fb3d24af1b411ffe17406a83e93.tar.gz
gnu: console-setup: Set absolute file name of 'cat' in 'ckbcomp'.
* gnu/packages/xorg.scm (console-setup)[arguments]: Add 'patch-file-names' phase.
-rw-r--r--gnu/packages/xorg.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b553d4534a..3463ac85a7 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6378,6 +6378,15 @@ output.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (add-after 'unpack 'patch-file-names
+ (lambda _
+ ;; 'ckbcomp' calls out to 'cat' (!). Give it the right file
+ ;; name.
+ (substitute* '("Keyboard/ckbcomp")
+ (("\"cat ")
+ (string-append "\"" (which "cat")
+ " ")))
+ #t))
(add-before 'build 'make-doubled-bdfs
(lambda* (#:key inputs #:allow-other-keys)
(invoke "make" "-C" "Fonts"