summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 12:43:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 15:04:02 +0100
commit1462e5c9198e22f1431d185e0b0ea28bff14db84 (patch)
tree753b3b6efb5440ab51391f589f858b6b3e62a687
parentc61e49aa94e7cd49344540f9718014aaf652dea3 (diff)
downloadguix-patches-1462e5c9198e22f1431d185e0b0ea28bff14db84.tar
guix-patches-1462e5c9198e22f1431d185e0b0ea28bff14db84.tar.gz
gnu: dropseq-tools: Remove trailing #T.
* gnu/packages/bioinformatics.scm (dropseq-tools)[arguments]: Remove trailing #T from build phases... [source]: ...and from the snippet.
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f3cc1eac89..35a03bb145 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10748,8 +10748,7 @@ contains
(snippet
'(begin
(for-each delete-file (find-files "jar/lib" "\\.jar$"))
- (delete-file-recursively "3rdParty")
- #t))))
+ (delete-file-recursively "3rdParty")))))
(build-system ant-build-system)
(arguments
`(#:tests? #f ; test data are not included
@@ -10786,8 +10785,7 @@ contains
(for-each (lambda (jar)
(symlink jar (string-append "jar/lib/" (basename jar))))
(append-map (lambda (dir) (find-files dir "\\.jar$"))
- dirs)))
- #t))
+ dirs)))))
;; There is no installation target
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -10830,8 +10828,7 @@ contains
scripts)
(("^java") (which "java"))
(("jar_deploy_dir=.*")
- (string-append "jar_deploy_dir=" share "\n"))))
- #t))
+ (string-append "jar_deploy_dir=" share "\n"))))))
;; FIXME: We do this after stripping jars because we don't want it to
;; copy all these jars and strip them. We only want to install
;; links. Arguably, this is a problem with the ant-build-system.
@@ -10843,8 +10840,7 @@ contains
(for-each (lambda (jar)
(symlink (readlink jar)
(string-append lib (basename jar))))
- (find-files "jar/lib" "\\.jar$")))
- #t)))))
+ (find-files "jar/lib" "\\.jar$"))))))))
(inputs
`(("jdk" ,icedtea-8)
("java-picard" ,java-picard-2.10.3)