summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-27 21:47:11 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-02-11 20:45:44 +0100
commiteccb1e0964e8e93a07b885c3a64033306735d179 (patch)
tree7221e385a70349861ebeb7389e08d5af37d7bec1
parent54b1d115c49e14b0bcca05b2a1d31e0f5451c53c (diff)
downloadguix-patches-eccb1e0964e8e93a07b885c3a64033306735d179.tar
guix-patches-eccb1e0964e8e93a07b885c3a64033306735d179.tar.gz
gnu: mutter: Disable timeline tests.
* gnu/packages/gnome.scm (mutter)[disable-problematic-tests]: Also disable timeline tests.
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index beab19805b..bb5b037736 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7478,7 +7478,12 @@ to display dialog boxes from the commandline and shell scripts.")
;; expression paragraph. For an explanation, see: info '(sed)
;; Multiline techniques'.
(invoke "sed" "/./{H;$!d} ; x ; s/^.*native-headless.*$//"
- "-i" "src/tests/meson.build")))
+ "-i" "src/tests/meson.build")
+ ;; Timeline tests may unexpectedly fail on missed frames, so
+ ;; let's disable them as well.
+ ;; See <https://gitlab.gnome.org/GNOME/mutter/-/issues/2125>
+ (substitute* "src/tests/clutter/conform/meson.build"
+ (("'timeline.*',") ""))))
(replace 'check
(lambda* (#:key tests? test-options parallel-tests?
#:allow-other-keys)