summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2017-03-04 22:10:41 -0800
committerLudovic Courtès <ludo@gnu.org>2017-03-07 16:44:02 +0100
commitaf1268752216829127b12d2043c36e64f0c48173 (patch)
tree314cbefbafa0ccdda2ac8b93456a59c78c03f7fe
parenteaa72e3a1112251b9ed39f51d5964263614b5747 (diff)
downloadguix-patches-af1268752216829127b12d2043c36e64f0c48173.tar
guix-patches-af1268752216829127b12d2043c36e64f0c48173.tar.gz
gnu: guile-lib: Update to 0.2.5
The build was broken since the URL of version 0.2.3 was changed. The archive was moved into an "old" subdirectory of the original location. * gnu/packages/guile.scm (guile-lib): Update to 0.2.5. [make-flags]: Add GUILE_AUTO_COMPILE to prevent guild errors. [phases]: Remove 'check replacement since it is no longer needed. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile.scm41
1 files changed, 19 insertions, 22 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 293579b1be..4440c6c602 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -632,32 +632,29 @@ The library is shipped with documentation in Info format and usage examples.")
(define-public guile-lib
(package
(name "guile-lib")
- (version "0.2.3")
+ (version "0.2.5")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://savannah/guile-lib/guile-lib-"
- version ".tar.gz"))
- (sha256
- (base32
- "0pwdd52vakni1fabaiav8v0ad7xp3bx8x3brijbr1mpgamm9dxqc"))))
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/guile-lib/guile-lib-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1qbk485djgxqrbfjvk4b7w7y4x9xygf2qb8dqnl7885kajasx8qg"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (add-before 'configure 'patch-module-dir
- (lambda _
- (substitute* "src/Makefile.in"
- (("^moddir = ([[:graph:]]+)")
- "moddir = $(datadir)/guile/site/@GUILE_EFFECTIVE_VERSION@\n")
- (("^godir = ([[:graph:]]+)")
- "godir = \
+ '(#:make-flags
+ '("GUILE_AUTO_COMPILE=0") ;to prevent guild errors
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-module-dir
+ (lambda _
+ (substitute* "src/Makefile.in"
+ (("^moddir = ([[:graph:]]+)")
+ "moddir = $(datadir)/guile/site/@GUILE_EFFECTIVE_VERSION@\n")
+ (("^godir = ([[:graph:]]+)")
+ "godir = \
$(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
- #t))
- (replace 'check
- (lambda _
- ;; Work around a harmless test failure involving
- ;; two-spaces-after-period rendering.
- (zero? (system* "make" "check" ;"-C" "unit-tests"
- "XFAIL_TESTS=texinfo.serialize.scm")))))))
+ #t)))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("guile" ,guile-2.0)))
(home-page "http://www.nongnu.org/guile-lib/")