summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-10 10:14:47 +0100
committerMarius Bakke <marius@gnu.org>2022-02-11 23:54:30 +0100
commit0d2f661501abc4e2e5558b18655ef135239450e8 (patch)
treec59e45415c8963bc0199984ba52589f1ac2f498b
parent0f1cb023628d738bb21425c1921d17672db4f890 (diff)
downloadguix-patches-0d2f661501abc4e2e5558b18655ef135239450e8.tar
guix-patches-0d2f661501abc4e2e5558b18655ef135239450e8.tar.gz
gnu: rav1e: Omit static library.
* gnu/packages/video.scm (rav1e)[arguments]: Add phase.
-rw-r--r--gnu/packages/video.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 244d12028d..221a2abff9 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2018-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018, 2019, 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
@@ -5322,7 +5322,12 @@ result in several formats:
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(invoke "cargo" "cinstall" "--release"
- (string-append "--prefix=" out))))))))
+ (string-append "--prefix=" out)))))
+ (add-after 'install 'delete-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Delete 80 MiB (!) static library.
+ (delete-file (string-append (assoc-ref outputs "out")
+ "/lib/librav1e.a")))))))
(native-inputs
`(("cargo-c" ,rust-cargo-c)
("nasm" ,nasm)))