summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-03 01:47:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-03 02:21:22 +0200
commitac68ab337cf09c99a71393002854f66ad495d2ee (patch)
tree94c02d3ede4cc0da08b5cf90cbc8cefc3651e8d1
parent3dec317f1d54855705fb08c156f758b194c52d5c (diff)
downloadguix-patches-ac68ab337cf09c99a71393002854f66ad495d2ee.tar
guix-patches-ac68ab337cf09c99a71393002854f66ad495d2ee.tar.gz
gnu: blktrace: Prepare for cross-compilation.
* gnu/packages/linux.scm (blktrace)[arguments]: Use CC-FOR-TARGET.
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 197e5ea85a..1e1ba787e2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4331,12 +4331,13 @@ applications.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags
- (list "CC=gcc" (string-append "prefix=" %output))
- #:tests? #f ; no tests
+ `(#:make-flags
+ (list ,(string-append "CC=" (cc-for-target))
+ (string-append "prefix=" %output))
+ #:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure script
+ (delete 'configure) ; no configure script
(add-after 'unpack 'fix-gnuplot-path
(lambda* (#:key inputs #:allow-other-keys)
(let ((gnuplot (assoc-ref inputs "gnuplot")))