summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-03 14:05:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-03 14:07:48 +0200
commit08542026ea6312545d20f408f1743a811ae18f85 (patch)
treeabd8b2e9efdfab510a479885be1d89b4a651cb54
parent7277baf50d348a11cd824379f1bb32beb83e7ffb (diff)
downloadguix-patches-08542026ea6312545d20f408f1743a811ae18f85.tar
guix-patches-08542026ea6312545d20f408f1743a811ae18f85.tar.gz
gnu: python-pybedtools: Disable unreliable test.
* gnu/packages/bioinformatics.scm (python-pybedtools)[arguments]: Disable test_intron_exon_reads test; run tests verbosely. test_intron_exon_reads
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cfa0263e46..97ad0fc2fd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -806,12 +806,13 @@ intended to behave exactly the same as the original BWK awk.")
;; See https://github.com/daler/pybedtools/issues/192
#:phases
(modify-phases %standard-phases
- ;; See https://github.com/daler/pybedtools/issues/261
(add-after 'unpack 'disable-broken-tests
(lambda _
- ;; This test (pybedtools.test.test_scripts.test_venn_mpl) needs a
- ;; graphical environment.
(substitute* "pybedtools/test/test_scripts.py"
+ ;; This test freezes.
+ (("def test_intron_exon_reads")
+ "def _do_not_test_intron_exon_reads")
+ ;; This test fails in the Python 2 build.
(("def test_venn_mpl")
"def _do_not_test_venn_mpl"))
(substitute* "pybedtools/test/test_helpers.py"
@@ -868,7 +869,7 @@ intended to behave exactly the same as the original BWK awk.")
(mkdir-p "/tmp/test")
(copy-recursively "pybedtools/test" "/tmp/test")
(with-directory-excursion "/tmp/test"
- (invoke "pytest")))))))
+ (invoke "pytest" "-v" "--doctest-modules")))))))
(propagated-inputs
`(("bedtools" ,bedtools)
("samtools" ,samtools)