summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-18 23:05:29 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-18 23:05:29 +0200
commitcbdd76c493e1f76ad9cb3b2e0fcc73b9591b768a (patch)
treec2cfd2b28cd8689b1edf1790687c96e62a89ddf6
parent19c9c266ae1de85e9d731e3ad829c8273b641c83 (diff)
downloadguix-patches-cbdd76c493e1f76ad9cb3b2e0fcc73b9591b768a.tar
guix-patches-cbdd76c493e1f76ad9cb3b2e0fcc73b9591b768a.tar.gz
gnu: Add python-matplotlib-inline.
* gnu/packages/python-xyz.scm (python-matplotlib-inline): New variable.
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e9c0f65353..1f45da0d0c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5973,6 +5973,30 @@ toolkits.")
(description (package-description python-matplotlib))
(license (package-license python-matplotlib))))
+(define-public python-matplotlib-inline
+ (package
+ (name "python-matplotlib-inline")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "matplotlib-inline" version))
+ (sha256
+ (base32 "1vilzwj3xp00mxprmmn1hlafm3p23vn56s46kx3ra4qd5signjx0"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-matplotlib" ,python-matplotlib)
+ ("python-traitlets" ,python-traitlets)))
+ (arguments
+ ;; Tests disabled because of a circular dependency with ipython.
+ `(#:tests? #f))
+ (home-page "https://github.com/ipython/matplotlib-inline")
+ (synopsis "Inline Matplotlib backend for Jupyter")
+ (description
+ "This package provides a Matplotlib inline back-end for IPython and
+Jupyter.")
+ (license license:bsd-3)))
+
(define-public python-matplotlib-venn
(package
(name "python-matplotlib-venn")