summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-18 12:08:23 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-18 12:12:48 +0200
commit68557cd2f3c6ca2ec317acb46dc3225c89178b7f (patch)
tree16c26dc5d9bddce5310c5f0339f820c376526493
parent4df5b64c8a62aeacf8531de39fd8568338535ece (diff)
downloadguix-patches-68557cd2f3c6ca2ec317acb46dc3225c89178b7f.tar
guix-patches-68557cd2f3c6ca2ec317acb46dc3225c89178b7f.tar.gz
gnu: grilo-plugins: Update to 0.3.13.
* gnu/packages/gnome.scm (grilo-plugins): Update to 0.3.13. [inputs]: Add python-pygobject and tracker-miners. [arguments]<#:phases>: Add 'set-shell and 'fix-tests phases.
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 37ae672a83..53455a3518 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6045,7 +6045,7 @@ for application developers.")
(define-public grilo-plugins
(package
(name "grilo-plugins")
- (version "0.3.11")
+ (version "0.3.13")
(source
(origin
(method url-fetch)
@@ -6053,7 +6053,7 @@ for application developers.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0wyd3n5mn7b77hxylkc3f62v01mlavh96901pz342hwrn42ydqnx"))))
+ (base32 "1y10nnd711qxwgpz6spzp1rnk50fyf11kk1n71a31ab4fgb0ahqw"))))
(build-system meson-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -6076,12 +6076,24 @@ for application developers.")
("libmediaart" ,libmediaart)
;("librest" ,rest) ; unused
("libsoup" ,libsoup)
+ ("python-pygobject" ,python-pygobject)
("totam-pl-parser" ,totem-pl-parser)
- ("tracker" ,tracker))) ; unused because it's too old
+ ("tracker" ,tracker)
+ ("tracker-miners" ,tracker-miners)))
(arguments
`(#:glib-or-gtk? #t
;;Disable lua-factory as it needs missing dependencies
- #:configure-flags '("-Denable-lua-factory=no")))
+ #:configure-flags '("-Denable-lua-factory=no")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-shell
+ (lambda _
+ (setenv "SHELL" (which "bash"))))
+ ;; Disable the tracker test that requires the UPower daemon.
+ (add-before 'configure 'fix-tests
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "tests/tracker3/meson.build"
+ (("'test_tracker3'.*") "")))))))
(home-page "https://live.gnome.org/Grilo")
(synopsis "Plugins for the Grilo media discovery library")
(description