summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-04-15 22:02:47 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-04-16 23:12:29 +0200
commit0160536dcb5399ad7d80b10e064df5c95f3adb4f (patch)
tree2f05ac8e60228dee8b294811e5de300269747605
parente967678ed1f1d7e765adc4bfc7d2a79ee9677b21 (diff)
downloadguix-patches-0160536dcb5399ad7d80b10e064df5c95f3adb4f.tar
guix-patches-0160536dcb5399ad7d80b10e064df5c95f3adb4f.tar.gz
gnu: Python: bump to version 2.7.4.
* gnu/packages/python.scm: bump to version 2.7.4, remove references to python-fix-dbm.patch. * Makefile.am: remove references to python-fix-dbm.patch * gnu/packages/patches/python-fix-dbm.patch: remove it.
-rw-r--r--Makefile.am1
-rw-r--r--gnu/packages/patches/python-fix-dbm.patch20
-rw-r--r--gnu/packages/python.scm9
3 files changed, 3 insertions, 27 deletions
diff --git a/Makefile.am b/Makefile.am
index 930ea6ce72..df0a5138dc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -229,7 +229,6 @@ dist_patch_DATA = \
gnu/packages/patches/make-impure-dirs.patch \
gnu/packages/patches/mcron-install.patch \
gnu/packages/patches/perl-no-sys-dirs.patch \
- gnu/packages/patches/python-fix-dbm.patch \
gnu/packages/patches/procps-make-3.82.patch \
gnu/packages/patches/qemu-multiple-smb-shares.patch \
gnu/packages/patches/readline-link-ncurses.patch \
diff --git a/gnu/packages/patches/python-fix-dbm.patch b/gnu/packages/patches/python-fix-dbm.patch
deleted file mode 100644
index 29e4521f3f..0000000000
--- a/gnu/packages/patches/python-fix-dbm.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-This patch allows the dbm module to be built using the compatibility mode of
-gdbm. It will not be needed any more with Python 2.7.4.
---- setup.py 2013-04-06 00:53:37.000000000 +0200
-+++ setup.py.new 2013-04-06 19:55:05.000000000 +0200
-@@ -1158,10 +1158,14 @@
- for cand in dbm_order:
- if cand == "ndbm":
- if find_file("ndbm.h", inc_dirs, []) is not None:
-- # Some systems have -lndbm, others don't
-+ # Some systems have -lndbm, some have -lgdbm_compat,
-+ # others have no particular linker flags.
- if self.compiler.find_library_file(lib_dirs,
- 'ndbm'):
- ndbm_libs = ['ndbm']
-+ elif self.compiler.find_library_file(lib_dirs,
-+ 'gdbm_compat'):
-+ ndbm_libs = ['gdbm_compat']
- else:
- ndbm_libs = []
- print "building dbm using ndbm"
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3f941642fc..8b4515930e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -31,7 +31,7 @@
(define-public python
(package
(name "python")
- (version "2.7.3")
+ (version "2.7.4")
(source
(origin
(method url-fetch)
@@ -39,12 +39,10 @@
version "/Python-" version ".tar.xz"))
(sha256
(base32
- "11f9aw855lrmknr6c82gm1ijr3n0smc6idyp94y7774yivjnplv1"))))
+ "0bdn4dylm92n2dsvqvjfyask9jbz88aan5hi4lgkawkxs2v6wqmn"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; XXX: some tests fail
- #:patches (list (assoc-ref %build-inputs "patch-dbm"))
- #:patch-flags '("-p0")
#:configure-flags
(let ((bz2 (assoc-ref %build-inputs "bzip2"))
(gdbm (assoc-ref %build-inputs "gdbm"))
@@ -68,8 +66,7 @@
("gdbm" ,gdbm)
("openssl" ,openssl)
("readline" ,readline)
- ("zlib" ,zlib)
- ("patch-dbm" ,(search-patch "python-fix-dbm.patch"))))
+ ("zlib" ,zlib)))
(home-page "http://python.org")
(synopsis
"Python, a high-level dynamically-typed programming language")