summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-01-02 14:43:41 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-02 18:13:07 +0100
commit60a290926b23f81427b17bc525b30cd1fc9e6508 (patch)
tree7115805fe72298d57bfd5ee672d67f230157ffcb
parent9dc6f288bfa00e2b16ab10a286d5dc41cedc8764 (diff)
downloadguix-patches-60a290926b23f81427b17bc525b30cd1fc9e6508.tar
guix-patches-60a290926b23f81427b17bc525b30cd1fc9e6508.tar.gz
distro: Add Berkeley DB.
* distro/packages/bdb.scm: New file. * Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--distro/packages/bdb.scm55
2 files changed, 56 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d0047312b..805ce446bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,7 @@ MODULES = \
distro/packages/check.scm \
distro/packages/compression.scm \
distro/packages/cpio.scm \
+ distro/packages/bdb.scm \
distro/packages/ddrescue.scm \
distro/packages/ed.scm \
distro/packages/flex.scm \
diff --git a/distro/packages/bdb.scm b/distro/packages/bdb.scm
new file mode 100644
index 0000000000..c926f91c11
--- /dev/null
+++ b/distro/packages/bdb.scm
@@ -0,0 +1,55 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages bdb)
+ #:use-module (distro)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public bdb
+ (package
+ (name "bdb")
+ (version "5.3.21")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.oracle.com/berkeley-db/db-" version
+ ".tar.gz"))
+ (sha256 (base32
+ "1f2g2612lf8djbwbwhxsvmffmf9d7693kh2l20195pqp0f9jmnfx"))))
+ (build-system gnu-build-system)
+ (arguments
+ (lambda (system)
+ `(#:tests? #f ; no check target available
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero?
+ (system* "./dist/configure"
+ (string-append "--prefix=" out)))))
+ %standard-phases))))
+ (synopsis "db, the Berkeley database")
+ (description
+ "Berkeley DB is an embeddable database allowing developers the choice of
+SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
+ (license (bsd-style "file://LICENSE"
+ "See LICENSE in the distribution."))
+ (home-page "http://www.oracle.com/us/products/database/berkeley-db/overview/index.html")))