summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Maleszka <adam_maleszka@aol.com>2022-02-07 16:47:56 +0100
committerLudovic Courtès <ludo@gnu.org>2022-02-10 23:24:41 +0100
commit854e38eeb7b007b6027364696615ec5eaa619c52 (patch)
treebb92cf876b693d05548285bc1fa9c303ff5c4582
parentd76cfc92dacd139fa565878a9a8e610c552094ef (diff)
downloadguix-patches-854e38eeb7b007b6027364696615ec5eaa619c52.tar
guix-patches-854e38eeb7b007b6027364696615ec5eaa619c52.tar.gz
gnu: bitlbee-discord: Update to 0.4.3-1.607f988.
Fixes <https://issues.guix.gnu.org/53840>. * gnu/packages/messaging.scm (bitlbee-discord): Update to 0.4.3-1.607f988. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/messaging.scm85
1 files changed, 48 insertions, 37 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index ca8a216661..92f310928d 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -713,44 +713,55 @@ identi.ca and status.net).")
#f)))))
(define-public bitlbee-discord
- (package
- (name "bitlbee-discord")
- (version "0.4.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sm00th/bitlbee-discord")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "00qgdvrp7hv02n0ns685igp810zxmv3adsama8601122al6x041n"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- (let ((out (assoc-ref %outputs "out")))
- (list (string-append "--with-bdatadir=" out "/share/bitlbee/")
- (string-append "--with-plugindir=" out "/lib/bitlbee/")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-autogen
- (lambda _
- (let ((sh (which "sh")))
- (substitute* "autogen.sh" (("/bin/sh") sh))
- (setenv "CONFIG_SHELL" sh)))))))
- (inputs (list glib))
- (native-inputs (list pkg-config
- autoconf
- automake
- texinfo
- libtool
- bitlbee ; needs bitlbee headers
- bash))
- (synopsis "Discord plugin for Bitlbee")
- (description "Bitlbee-discord is a plugin for Bitlbee which provides
+ ;; Version 0.4.3 of bitlbee-discord was prepared to work for
+ ;; glib@2.68. However, version 2.69 of glib introduced a breaking change
+ ;; causing bitlbee-discord to throw:
+ ;;
+ ;; discord - Login error: Failed to switch to websocket mode
+ ;;
+ ;; This makes the plugin unable to connect and therefore unusable:
+ ;; https://github.com/sm00th/bitlbee-discord/issues/226
+ ;; The specified commit fixes incompatibility with glib@2.69 and newer.
+ (let ((commit "607f9887ca85f246e970778e3d40aa5c346365a7")
+ (revision "1"))
+ (package
+ (name "bitlbee-discord")
+ (version (git-version "0.4.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sm00th/bitlbee-discord")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jkwhx2walx2ay0vc9x13q0j1qq4r5x30ss03a3j7ks28xvsnxc7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "--with-bdatadir=" out "/share/bitlbee/")
+ (string-append "--with-plugindir=" out "/lib/bitlbee/")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-autogen
+ (lambda _
+ (let ((sh (which "sh")))
+ (substitute* "autogen.sh" (("/bin/sh") sh))
+ (setenv "CONFIG_SHELL" sh)))))))
+ (inputs (list glib))
+ (native-inputs (list pkg-config
+ autoconf
+ automake
+ texinfo
+ libtool
+ bitlbee ; needs bitlbee headers
+ bash))
+ (synopsis "Discord plugin for Bitlbee")
+ (description "Bitlbee-discord is a plugin for Bitlbee which provides
access to servers running the Discord protocol.")
- (home-page "https://github.com/sm00th/bitlbee-discord/")
- (license license:gpl2+)))
+ (home-page "https://github.com/sm00th/bitlbee-discord/")
+ (license license:gpl2+))))
(define-public purple-mattermost
;; The latest release (1.2) only supports Mattermost's /api/v3. Choose a