summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-02-11 15:18:14 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-02-11 15:19:15 +0100
commit4ba7aab96503aa8e4b450fca1e68ca79eef3a534 (patch)
tree1f6b857cf5a553057f2f56bad720e66f88938a66
parenta4667135284db2f0956a87fc7444c866b046ad31 (diff)
downloadguix-patches-4ba7aab96503aa8e4b450fca1e68ca79eef3a534.tar
guix-patches-4ba7aab96503aa8e4b450fca1e68ca79eef3a534.tar.gz
gnu: Add cl-hamcrest.
* gnu/packages/lisp-check.scm (cl-hamcrest, ecl-hamcrest, sbcl-hamcrest): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-check.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 1cdd7d8300..4e6334ff86 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019, 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -358,6 +359,44 @@ interactive development model in mind.")
(define-public ecl-fiveam
(sbcl-package->ecl-package sbcl-fiveam))
+(define-public sbcl-hamcrest
+ (let ((commit "a54553e59a70dc5a539b683e79bfcdb0e8bae5c8")
+ (revision "0"))
+ (package
+ (name "sbcl-hamcrest")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/40ants/cl-hamcrest")
+ (commit commit)))
+ (sha256
+ (base32 "181nnb2fjbsdqjqdvwg2x9n1jjalkfzszwdgqcap4py2q63q1kxj"))
+ (file-name (git-file-name "cl-hamcrest" commit))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-iterate
+ sbcl-split-sequence
+ sbcl-cl-ppcre
+ sbcl-alexandria
+ sbcl-rove
+ sbcl-prove))
+ (home-page "https://40ants.com/cl-hamcrest/")
+ (synopsis "Make CL unit tests more readable")
+ (description
+ "@code{cl-hamcrest} is an implementation of the Hamcrest idea in
+Common Lisp. It simplifes unit tests and makes them more readable.
+Hamcrest uses the idea of pattern-matching, to construct matchers from
+different pieces and to apply them to the data.")
+ (license license:bsd-3))))
+
+(define-public cl-hamcrest
+ (sbcl-package->cl-source-package sbcl-hamcrest))
+
+(define-public ecl-cl-hamcrest
+ (sbcl-package->ecl-package sbcl-hamcrest))
+
(define-public sbcl-hu.dwim.stefil
(let ((commit "414902c6f575818c39a8a156b8b61b1adfa73dad"))
(package