summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-07 23:57:08 -0400
committerMark H Weaver <mhw@netris.org>2015-08-08 00:01:44 -0400
commit014cbde612f89bc9101e6932f64113415230e9f9 (patch)
treee9a574ce76743e559fc276560c477884c14070a4
parenta5e55dfbb7318f8c79e9d56f8c8dcd5b20566efb (diff)
downloadguix-patches-014cbde612f89bc9101e6932f64113415230e9f9.tar
guix-patches-014cbde612f89bc9101e6932f64113415230e9f9.tar.gz
gnu: aalib: Pass --build to configure.
* gnu/packages/video.scm (aalib)[arguments]: In configure phase, accept 'build' keyword argument and pass it to 'configure'.
-rw-r--r--gnu/packages/video.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c57c6c6700..e7fbd6720a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -97,7 +97,7 @@
'(#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key build inputs outputs #:allow-other-keys)
;; This old `configure' script doesn't support
;; variables passed as arguments.
(let ((out (assoc-ref outputs "out"))
@@ -105,6 +105,7 @@
(setenv "CONFIG_SHELL" (which "bash"))
(zero? (system* "./configure"
(string-append "--prefix=" out)
+ (string-append "--build=" build)
(string-append "--with-ncurses="
ncurses)))))))))
(home-page "http://aa-project.sourceforge.net/aalib/")