summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-13 00:54:52 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-14 17:42:08 +0200
commite22ab6a1b4c31f42c19e059cc9f25f4ceeb78a49 (patch)
tree73bbec1e4331ed5ec9d78f34ba27e578fe50df97
parent66ec389580d4f1e4b81e1c72afe2749a547a0e7c (diff)
downloadguix-patches-e22ab6a1b4c31f42c19e059cc9f25f4ceeb78a49.tar
guix-patches-e22ab6a1b4c31f42c19e059cc9f25f4ceeb78a49.tar.gz
gnu: Add emacs-undo-propose-el.
* gnu/packages/emacs-xyz.scm (emacs-undo-propose-el): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c8cd3a7ed5..d0ef3c0da1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14294,6 +14294,32 @@ command\", but because it always involves at least two commands (a prefix and
a suffix) we prefer to call it just a \"transient\".")
(license license:gpl3+))))
+(define-public emacs-undo-propose-el
+ (let ((commit "5f1fa99a04369a959aad01b476fe4f34229f28cd")
+ (version "1.0.0")
+ (revision "1"))
+ (package
+ (name "emacs-undo-propose-el")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jackkamm/undo-propose-el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1p9h1fqmva07mcs46rqrg9vqn537b615as84s9b7xh76k1r8h1c0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jackkamm/undo-propose-el")
+ (synopsis "Simple and safe navigation of @code{undo} history")
+ (description "This package permits navigation of @code{undo} history in a
+temporary buffer, which is read-only save for @code{undo} commands, and
+subsequent committal of a chain of @code{undo} commands as a single edit in
+the @code{undo} history.")
+ (license license:gpl3+))))
+
(define-public emacs-semantic-refactor
;; The last release, 0.5, was made on 2015-07-26 and there have been 47
;; commits since then.