summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-13 00:55:31 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-14 17:42:08 +0200
commit5b947258c82592ac51aeb8a1b5397badf9761585 (patch)
tree7cf929ad49c25908078289776844f7eba8777966
parente22ab6a1b4c31f42c19e059cc9f25f4ceeb78a49 (diff)
downloadguix-patches-5b947258c82592ac51aeb8a1b5397badf9761585.tar
guix-patches-5b947258c82592ac51aeb8a1b5397badf9761585.tar.gz
gnu: Add emacs-elisp-docstring-mode.
* gnu/packages/emacs-xyz.scm (emacs-elisp-docstring-mode): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d0ef3c0da1..c7e4091adb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14320,6 +14320,30 @@ subsequent committal of a chain of @code{undo} commands as a single edit in
the @code{undo} history.")
(license license:gpl3+))))
+(define-public emacs-elisp-docstring-mode
+ (let ((commit "f512e509dd690f65133e55563ebbfd2dede5034f")
+ (version "0.0.1")
+ (revision "1"))
+ (package
+ (name "emacs-elisp-docstring-mode")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Fuco1/elisp-docstring-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0al8m75p359h4n82rf0dsl22qfdg9cwwywn5pn7x6gb96c7qrqaa"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Fuco1/elisp-docstring-mode")
+ (synopsis "Major mode for editing Emacs Lisp docstrings")
+ (description "This package provides font lock and automatic escaping and
+unescaping of quotes.")
+ (license license:gpl3+))))
+
(define-public emacs-semantic-refactor
;; The last release, 0.5, was made on 2015-07-26 and there have been 47
;; commits since then.