summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVicente Vera Parra <vicentemvp@gmail.com>2015-09-15 14:18:58 -0300
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-21 10:48:26 +0200
commit3f8ac35330922507f4159b4bd670d5f50ea82673 (patch)
tree96c484d1f0166f29682ca3809a3a835231ec3046
parentacbb40fa2076c13aefa43c9d92474481cef110e4 (diff)
downloadguix-patches-3f8ac35330922507f4159b4bd670d5f50ea82673.tar
guix-patches-3f8ac35330922507f4159b4bd670d5f50ea82673.tar.gz
gnu: Add r-markdown.
* gnu/packages/statistics.scm (r-markdown): New variable.
-rw-r--r--gnu/packages/statistics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 82a1fb8291..84e5a21220 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -637,3 +637,29 @@ supported via Andre Simon's highlight package.")
"This package guesses the MIME type from a filename extension using the
data derived from /etc/mime.types in UNIX-type systems.")
(license license:gpl2)))
+
+(define-public r-markdown
+ (package
+ (name "r-markdown")
+ (version "0.7.7")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "markdown" version))
+ (sha256
+ (base32
+ "00j1hlib3il50azs2vlcyhi0bjpx1r50mxr9w9dl5g1bwjjc71hb"))))
+ (build-system r-build-system)
+ ;; Skip check phase because the tests require the r-knitr package to be
+ ;; installed. This prevents installation failures. Knitr normally
+ ;; shouldn't be available since r-markdown is a dependency of the r-knitr
+ ;; package.
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("r-mime" ,r-mime)))
+ (home-page "https://github.com/rstudio/markdown")
+ (synopsis "Markdown rendering for R")
+ (description
+ "This package provides R bindings to the Sundown Markdown rendering
+library (https://github.com/vmg/sundown). Markdown is a plain-text formatting
+syntax that can be converted to XHTML or other formats.")
+ (license license:gpl2)))