summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-09 22:28:12 +0100
committerMarius Bakke <marius@gnu.org>2022-02-10 00:21:46 +0100
commit6ff0a6d53a4f5c3faa4a4b6503dab47ea2cc2426 (patch)
treeec3a85b1bb6d5c297a71f7db62c14773bc1d5978
parenta87ec50b394cffebb6f19b3689fc12c71f974d40 (diff)
downloadguix-patches-6ff0a6d53a4f5c3faa4a4b6503dab47ea2cc2426.tar
guix-patches-6ff0a6d53a4f5c3faa4a4b6503dab47ea2cc2426.tar.gz
gnu: cpplint: Update to 1.5.5.
* gnu/packages/cpp.scm (cpplint): Update to 1.5.5. [arguments]: Remove obsolete phase. Override check phase. [native-inputs]: Add PYTHON-COVERAGE and PYTHON-TESTFIXTURES.
-rw-r--r--gnu/packages/cpp.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index a77ac84f17..09ba10d9ab 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -74,6 +74,7 @@
#:use-module (gnu packages onc-rpc)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
#:use-module (gnu packages pretty-print)
@@ -766,7 +767,7 @@ library.")
(define-public cpplint
(package
(name "cpplint")
- (version "1.4.5")
+ (version "1.5.5")
(source
(origin
(method git-fetch)
@@ -776,19 +777,22 @@ library.")
(url "https://github.com/cpplint/cpplint")
(commit version)))
(sha256
- (base32 "1yzcxqx0186sh80p0ydl9z0ld51fn2cdpz9hmhrp15j53g9ira7c"))
+ (base32 "13l86aq0h1jga949k79k9x3hw2xqchjc162sclg2f99vz98zcz15"))
(file-name (git-file-name name version))))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'use-later-pytest
- (lambda _
- (substitute* "test-requirements"
- (("pytest.*") "pytest\n"))
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(build-system python-build-system)
(native-inputs
- (list python-pytest python-pytest-cov python-pytest-runner))
+ (list python-coverage
+ python-pytest
+ python-pytest-cov
+ python-pytest-runner
+ python-testfixtures))
(home-page "https://github.com/cpplint/cpplint")
(synopsis "Static code checker for C++")
(description "@code{cpplint} is a command-line tool to check C/C++ files