summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-08 23:55:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-09 09:02:24 +0100
commit61d1d4a3c5420acef48376871021709b00fc9d2f (patch)
treed6fcbee18e1fc89672240ac8d2265259f037b2f4
parent98a4da8a13d792188c144f7e31538caa00f90cc3 (diff)
downloadguix-patches-61d1d4a3c5420acef48376871021709b00fc9d2f.tar
guix-patches-61d1d4a3c5420acef48376871021709b00fc9d2f.tar.gz
gnu: Add r-swne.
* gnu/packages/statistics.scm (r-swne): New variable.
-rw-r--r--gnu/packages/statistics.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index a07540417f..648462be03 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6106,6 +6106,60 @@ knowledge integration, designable W and H matrices and multiple forms of
regularizations.")
(license license:bsd-2))))
+(define-public r-swne
+ (let ((commit "05fc3ee4e09b2c34d99c69d3b97cece4c1c34143")
+ (revision "1"))
+ (package
+ (name "r-swne")
+ (version (git-version "0.6.20" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yanwu2014/swne")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0crlpg9kclbv4v8250p3086a3lk6f2hcq79psqkdylc1qnrx3kfx"))))
+ (properties `((upstream-name . "swne")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-fnn
+ r-ggplot2
+ r-ggrepel
+ r-hash
+ r-ica
+ r-igraph
+ r-irlba
+ r-jsonlite
+ r-liger
+ r-mass
+ r-matrix
+ r-mgcv
+ r-nnlm ;not listed but required at install time
+ r-plyr
+ r-proxy
+ r-rcolorbrewer
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppeigen
+ r-reshape
+ r-reshape2
+ r-snow
+ r-umap
+ r-usedist))
+ (home-page "https://github.com/yanwu2014/swne")
+ (synopsis "Visualize high dimensional datasets")
+ (description
+ "@dfn{Similarity Weighted Nonnegative Embedding} (SWNE) is a method for
+visualizing high dimensional datasets. SWNE uses Nonnegative Matrix
+Factorization to decompose datasets into latent factors, projects those
+factors onto 2 dimensions, and embeds samples and key features in 2 dimensions
+relative to the factors. SWNE can capture both the local and global dataset
+structure, and allows relevant features to be embedded directly onto the
+visualization, facilitating interpretation of the data.")
+ (license license:gpl2))))
+
(define-public python-rpy2
(package
(name "python-rpy2")