summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-11-27 22:07:17 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-09 14:37:41 -0500
commit3282d6c24fb492a783690a9594779d2b611c0da3 (patch)
tree923bfb8c0815717d9fc24e6947cb4e3f58b0558d
parent1a4cc954d2fcea172a450ae03419b7fdda28b81e (diff)
downloadguix-patches-3282d6c24fb492a783690a9594779d2b611c0da3.tar
guix-patches-3282d6c24fb492a783690a9594779d2b611c0da3.tar.gz
gnu: Add glad.
* gnu/packages/gl.scm (glad): New variable.
-rw-r--r--gnu/packages/gl.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index b71bc2d490..0ff39dc24d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
-;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
@@ -63,6 +63,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system python)
#:use-module (guix build-system waf)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -181,6 +182,38 @@ rendering modes are: Bitmaps, Anti-aliased pixmaps, Texture maps, Outlines,
Polygon meshes, and Extruded polygon meshes.")
(license license:x11)))
+(define-public glad
+ (package
+ (name "glad")
+ (version "0.1.36")
+ (source
+ (origin
+ ;; We fetch the sources from the repository since the PyPI archive
+ ;; doesn't contain the CMakeLists.txt file which is useful for
+ ;; integration with other software, such as the openboardview package.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dav1dde/glad")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0m55ya1zrmg6n2cljkajy80ilmi5sblln8742fm0k1sw9k7hzn8n"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-cmakelists.txt
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (share (string-append out "/share/" ,name)))
+ (install-file "CMakeLists.txt" share)))))))
+ (home-page "https://github.com/Dav1dde/glad")
+ (synopsis "Multi-language GL/GLES/EGL/GLX/WGL loader generator")
+ (description "Glad uses the official Khronos XML specifications to
+generate a GL/GLES/EGL/GLX/WGL loader tailored for specific requirements.")
+ (license license:expat)))
+
(define-public s2tc
(package
(name "s2tc")