summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@tutanota.com>2022-02-07 10:31:13 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-09 15:33:24 +0100
commit1ef73d5bea6215b1172c296063b9c5b94a4d849d (patch)
tree74ba0a08156af173a3995c6cef61ed8d55cebc39
parent28e40fc369464ed12c519e76c9e36320b4d3c460 (diff)
downloadguix-patches-1ef73d5bea6215b1172c296063b9c5b94a4d849d.tar
guix-patches-1ef73d5bea6215b1172c296063b9c5b94a4d849d.tar.gz
gnu: searx: Fix build.
* gnu/packages/search.scm (searx)[arguments]<#:phases>: Simplify relax-requirements phase for updated dependencies. Add phase to allow sanity check to pass. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/search.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 7e3d9b1cbd..dbca2b3c08 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -243,16 +243,15 @@ command line tool for interacting with libtocc.")
(modify-phases %standard-phases
(add-after 'unpack 'relax-requirements
(lambda _
- ;; These packages are outdated in Guix at the time of packaging.
- ;; When they are updated, remove corresponding substitutions.
;; Tests can run after build with 'searx-checker' tool in /bin.
+ ;; allow using a higher dependency version
(substitute* "requirements.txt"
- (("flask-babel==2.0.0") "flask-babel>=1.0.0")
- (("jinja2==2.11.3") "jinja2>=2.11.2")
- (("lxml==4.6.3") "lxml>=4.4.2")
- (("pygments==2.8.0") "pygments>=2.7.3")
- (("requests\\[socks\\]==2.25.1") "requests>=2.25")
- (("==") ">=")))))))
+ (("==") ">="))))
+ (add-before 'sanity-check 'set-debug
+ (lambda _
+ ;; the user will need to change the secret key
+ ;; https://github.com/searx/searx/issues/2278
+ (setenv "SEARX_DEBUG" "1"))))))
(propagated-inputs
(list python-babel
python-certifi