summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-08 09:19:55 +0100
committerMarius Bakke <marius@gnu.org>2022-02-10 00:21:46 +0100
commit15168f2432302cec8e5eba7dc170bee1fa9fd9ea (patch)
tree9d697044743538e733f15e3ecd165faa29d99ded
parent32ccbc3a1ebf62d90f618ababb206df57f7e767b (diff)
downloadguix-patches-15168f2432302cec8e5eba7dc170bee1fa9fd9ea.tar
guix-patches-15168f2432302cec8e5eba7dc170bee1fa9fd9ea.tar.gz
gnu: python-importmagic: Fix test failure.
* gnu/packages/python-xyz.scm (python-importmagic)[arguments]: Replace check phase. [native-inputs]: Add PYTHON-PYTEST.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 537a2eef35..41b60325d2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8243,6 +8243,15 @@ need to use the older and less efficient @code{pkg_resources} package.")
(base32
"1n7qxa1snj06aw45mcfz7bxc46zp7fxj687140g2k6jcnyjmfxrz"))))
(build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-v")))))))
+ (native-inputs
+ (list python-pytest))
(home-page "https://github.com/alecthomas/importmagic")
(synopsis "Library for adding, removing and managing Python imports")
(description