summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 00:13:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 16:33:09 -0500
commitec1b5f85e7901bd96cc1143dce6fbef970821e17 (patch)
tree85a17656b99f9acd16f39c5bb73b3e1ee64761f2
parentbb33b497899e84dfc81957c44c796e59bdc17587 (diff)
downloadguix-patches-ec1b5f85e7901bd96cc1143dce6fbef970821e17.tar
guix-patches-ec1b5f85e7901bd96cc1143dce6fbef970821e17.tar.gz
gnu: python-simplejson: Update to 3.17.2, fixing build.
* gnu/packages/python-xyz.scm (python-simplejson): Update to 3.17.2. [native-inputs]: Add python-toml.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 66db6a0116..ac0ddb82a4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1929,16 +1929,18 @@ audio playback capability for Python 3 on OSX, Windows, and Linux.")
(define-public python-simplejson
(package
(name "python-simplejson")
- (version "3.17.0")
+ (version "3.17.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "simplejson" version))
(sha256
(base32
- "108yf3252fy4ndqab7h46raksxfhcn113bzy2yd8369vidrjnjrb"))))
+ "0hc8nqwdlll4a9cr1k9msn5kmb6kmbjirpgvhjh254nr4sgwgv3m"))))
(build-system python-build-system)
- (home-page "http://simplejson.readthedocs.org/en/latest/")
+ (native-inputs
+ `(("python-toml" ,python-toml)))
+ (home-page "https://simplejson.readthedocs.io/en/latest")
(synopsis
"Json library for Python")
(description