summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-14 12:50:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-14 14:45:22 +0300
commita5dc1742090dd7854c03f23b0717ff4f7388967b (patch)
tree37137832ee1d5fc6473d1a625758afc5071d18a4
parente490262fbd502222801aa15a1680b728dc76d533 (diff)
downloadguix-patches-a5dc1742090dd7854c03f23b0717ff4f7388967b.tar
guix-patches-a5dc1742090dd7854c03f23b0717ff4f7388967b.tar.gz
gnu: Add julia-mosaicviews.
* gnu/packages/julia-xyz.scm (julia-mosaicviews): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index e5a123acb7..da4af95bdf 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2090,6 +2090,38 @@ with @code{missing} values in Julia.")
to be temporarily overloaded for the purpose of testing.")
(license license:expat)))
+(define-public julia-mosaicviews
+ (package
+ (name "julia-mosaicviews")
+ (version "0.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaArrays/MosaicViews.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04fgxghyb7n2ji76xkb1r1fjhzsdbgmp5wsfyyn3yjcsdqbyp8pz"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:tests? #f)) ; Cycle with ImageCore.jl
+ (propagated-inputs
+ `(("julia-mappedarrays" ,julia-mappedarrays)
+ ("julia-paddedviews" ,julia-paddedviews)
+ ("julia-stackviews" ,julia-stackviews)))
+ ;(native-inputs
+ ; `(("julia-colorvectorspace" ,julia-colorvectorspace)
+ ; ("julia-imagecore" ,julia-imagecore)))
+ (home-page "https://github.com/JuliaArrays/MosaicViews.jl")
+ (synopsis
+ "Lazily view a 3D or 4D array as an expanded 2D array as a matrix of slices")
+ (description "When visualizing images, it is not uncommon to provide a 2D
+view of different image sources. For example, comparing multiple images of
+different sizes, getting a preview of machine learning dataset. This package
+aims to provide easy-to-use tools for such tasks.")
+ (license license:expat)))
+
(define-public julia-msgpack
(package
(name "julia-msgpack")