summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-17 00:32:24 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-18 23:19:51 +0200
commit92d581a0fd9118d8586aff2746339007f67da232 (patch)
tree24d114f3e59abe14a10d461b114170420f614502
parenta749040ad740016fd24c296bf2286c7aedca2b57 (diff)
downloadguix-patches-92d581a0fd9118d8586aff2746339007f67da232.tar
guix-patches-92d581a0fd9118d8586aff2746339007f67da232.tar.gz
gnu: emacs-image+: Don't propagate inputs.
* gnu/packages/emacs.scm (emacs-image+)[propagated-inputs]: Remove imagemagick [Inputs]: Add imagemagick [arguments]: Substitute path to imagemagick commands Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 793d4030b6..70b63274c5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11217,7 +11217,22 @@ provided by other Emacs packages dealing with pass:
(base32
"0v66wk9nh0raih4jhrzmmyi5lbysjnmbv791vm2230ffi2hmwxnd"))))
(build-system emacs-build-system)
- (propagated-inputs `(("imagemagick" ,imagemagick)))
+ (inputs `(("imagemagick" ,imagemagick)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((imagemagick (assoc-ref inputs "imagemagick")))
+ ;; Specify the absolute file names of the various
+ ;; programs so that everything works out-of-the-box.
+ (chmod "image+.el" #o666)
+ (emacs-substitute-variables
+ "image+.el"
+ ("imagex-convert-command"
+ (string-append imagemagick "/bin/convert"))
+ ("imagex-identify-command"
+ (string-append imagemagick "/bin/identify")))))))))
(home-page "https://github.com/mhayashi1120/Emacs-imagex")
(synopsis "Image manipulation extensions for Emacs")
(description