summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-19 16:06:18 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-19 16:20:35 -0400
commit82d1e90aaa08cbced55dd787355a2538f00b1628 (patch)
tree2339e2f6b9b7c52923be370b9fcc72cdc70c5532
parentb865a21c3475b2c66a0b5cf07d0a0e4221a92516 (diff)
downloadguix-patches-82d1e90aaa08cbced55dd787355a2538f00b1628.tar
guix-patches-82d1e90aaa08cbced55dd787355a2538f00b1628.tar.gz
gnu: python-xmlschema: Update to 1.2.5.
* gnu/packages/xml.scm (python-xmlschema): Update to 1.2.5. [phases]{check}: Skip the failing test 'test_export_remote__issue_187'.
-rw-r--r--gnu/packages/xml.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index dddb056a0f..f5e2f58459 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2258,7 +2258,7 @@ libxml2 and libxslt.")
(define-public python-xmlschema
(package
(name "python-xmlschema")
- (version "1.1.2")
+ (version "1.2.5")
(source (origin
;; Unit tests are not distributed with the PyPI archive.
(method git-fetch)
@@ -2268,7 +2268,7 @@ libxml2 and libxslt.")
(file-name (git-file-name name version))
(sha256
(base32
- "03bz5mp45y4shmlc1gxq1h69vjx60z1acg9cy4kq7fczgx8qg9jw"))))
+ "0rsa75x86gdjalvy4riq7613szb616hff80crx006chyppzdkxmq"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -2280,7 +2280,11 @@ libxml2 and libxslt.")
(setenv "PYTHONPATH"
(string-append "./build/lib:"
(getenv "PYTHONPATH")))
- (invoke "python" "-m" "unittest" "-v"))
+ ;; Disable test_export_remote__issue_187, which is known to
+ ;; fail (see:
+ ;; https://github.com/sissaschool/xmlschema/issues/206).
+ (invoke "python" "-m" "unittest" "-v"
+ "-k" "not test_export_remote__issue_187"))
(format #t "test suite not run~%"))
#t)))))
(native-inputs