summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-04-16 09:30:44 +0100
committerChristopher Baines <mail@cbaines.net>2020-10-21 18:22:12 +0100
commit28a13226fd5cd08b3eb090151c0753424c3f6eb4 (patch)
treeb0ccac480d795c8e4bf9745f98384f3b6a2f18fb
parent6731fc6ab891c3d6c4f762d54a45e79a4ae40dad (diff)
downloadguix-patches-28a13226fd5cd08b3eb090151c0753424c3f6eb4.tar
guix-patches-28a13226fd5cd08b3eb090151c0753424c3f6eb4.tar.gz
gnu: gnutls: Enable p11-kit.
Everywhere except mips64el, where a comment says it doesn't work. I can't test as I can't build this on mips64el anyway. This change will enable running the tests for libcacard. * gnu/packages/tls.scm (gnutls)[arguments]: Only specify --without-p11-kit on mips64el. [inputs]: Include the p11-kit for all systems except mips64el.
-rw-r--r--gnu/packages/tls.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 0f38d937d3..a3d00703b1 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -188,7 +188,7 @@ living in the same process.")
'()
(list net-tools iproute socat))
#:configure-flags
- (list
+ (cons*
;; GnuTLS doesn't consult any environment variables to specify
;; the location of the system-wide trust store. Instead it has a
;; configure-time option. Unless specified, its configure script
@@ -209,9 +209,14 @@ living in the same process.")
(string-append "--with-guile-extension-dir="
"$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions")
- ;; FIXME: Temporarily disable p11-kit support since it is not
- ;; working on mips64el.
- "--without-p11-kit")
+ (let ((system ,(or (%current-target-system)
+ (%current-system))))
+ (if (string-prefix? "mips64el" system)
+ (list
+ ;; FIXME: Temporarily disable p11-kit support since it is
+ ;; not working on mips64el.
+ "--without-p11-kit")
+ '())))
#:phases (modify-phases %standard-phases
;; fastopen.sh fails to connect to the server in the builder
@@ -250,7 +255,12 @@ living in the same process.")
`(("datefudge" ,datefudge))) ;tests rely on 'datefudge'
("util-linux" ,util-linux))) ;one test needs 'setsid'
(inputs
- `(("guile" ,guile-3.0)))
+ `(("guile" ,guile-3.0)
+ ,@(let ((system (or (%current-target-system)
+ (%current-system))))
+ (if (string-prefix? "mips64el" system)
+ '()
+ `(("p11-kit" ,p11-kit))))))
(propagated-inputs
;; These are all in the 'Requires.private' field of gnutls.pc.
`(("libtasn1" ,libtasn1)