summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-05-31 19:50:07 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-04 22:34:32 +0200
commit2d092a2afae60421157b486c4056f12ba6d0d20a (patch)
tree7c431ba2e827ec6f2a3d64125812f9d0af3e7330
parentc4989f756908f258d2516465e15a807059a1744c (diff)
downloadguix-patches-2d092a2afae60421157b486c4056f12ba6d0d20a.tar
guix-patches-2d092a2afae60421157b486c4056f12ba6d0d20a.tar.gz
gnu: gess: Set #:guile argument of 'wrap-script'.
* gnu/packages/bioinformatics.scm (gess)[arguments]<#:phases>{install} Set #:guile argument of ‘wrap-script’. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/bioinformatics.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 37483984ec..965e26b812 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7554,7 +7554,7 @@ experience substantial biological insertions and deletions.")
(delete 'configure)
(delete 'build)
(replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(scripts (find-files "." "prinseq.*.pl"))
@@ -10239,6 +10239,7 @@ matplotlib.use('Agg')
" line)))
;; Make sure GESS has all modules in its path
(wrap-script (string-append target "GESS.py")
+ #:guile (search-input-file inputs "bin/guile")
`("GUIX_PYTHONPATH" ":" = (,target ,(getenv "GUIX_PYTHONPATH"))))
(mkdir-p bin)
(symlink (string-append target "GESS.py")