summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-05-31 19:41:22 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-04 22:34:32 +0200
commit0a843e36434f3e99bed7b591f22b7b04406e4890 (patch)
tree94c4365e1d5e13df60c676b9e7dd0ac8f2794dd7
parenta62d17dc05f60f242f577ab97db20380f701432d (diff)
downloadguix-patches-0a843e36434f3e99bed7b591f22b7b04406e4890.tar
guix-patches-0a843e36434f3e99bed7b591f22b7b04406e4890.tar.gz
gnu: carla: Set #:guile argument of 'wrap-script'.
* gnu/packages/audio.scm (carla)[arguments]<#:phases>{wrap-executables}: Set #:guile argument of ‘wrap-script’. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/audio.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f677d46a7f..930c111d5e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4711,9 +4711,10 @@ as is the case with audio plugins.")
(chmod (string-append out "/share/carla/carla") #o555)
#t)))
(add-after 'install 'wrap-executables
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(wrap-script (string-append out "/bin/carla")
+ #:guile (search-input-file inputs "bin/guile")
`("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH"))))
#t))))))
(inputs