summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 10:17:09 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:40:34 -0400
commitfeb246fbff8256255b939e25317375588aba1fc7 (patch)
tree26f9bc0ea36e3e48d7401fb4f273f6dcbb1cfd2b
parent406639254282b1979fef398e93393b24bdb6db58 (diff)
downloadguix-patches-feb246fbff8256255b939e25317375588aba1fc7.tar
guix-patches-feb246fbff8256255b939e25317375588aba1fc7.tar.gz
gnu: pango: Re-arrange inputs in alphabetical order.
* gnu/packages/gtk.scm (pango) [propagated-inputs]: Modify. [native-inputs]: Modify. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm35
1 files changed, 17 insertions, 18 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index d8c119a6df..6eeb0abd2b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -336,24 +336,23 @@ applications.")
(("\\[ 'test-itemize'.*") "")
(("\\[ 'test-layout'.*") ""))
#t)))))
- (propagated-inputs
- ;; These are all in Requires or Requires.private of the '.pc' files.
- `(("cairo" ,cairo)
- ("fribidi" ,fribidi)
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("glib" ,glib)
- ("harfbuzz" ,harfbuzz)
-
- ;; Some packages, such as Openbox, expect Pango to be built with the
- ;; optional libxft support.
- ("libxft" ,libxft)))
- (inputs
- `(("zlib" ,zlib)))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("glib" ,glib "bin") ; glib-mkenums, etc.
- ("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
+ (propagated-inputs
+ ;; These are all in Requires or Requires.private of the '.pc' files.
+ `(("cairo" ,cairo)
+ ("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("fribidi" ,fribidi)
+ ("glib" ,glib)
+ ("harfbuzz" ,harfbuzz)
+ ;; Some packages, such as Openbox, expect Pango to be built with the
+ ;; optional libxft support.
+ ("libxft" ,libxft)))
+ (inputs
+ `(("zlib" ,zlib)))
+ (native-inputs
+ `(("glib" ,glib "bin") ; glib-mkenums, etc.
+ ("gobject-introspection" ,gobject-introspection) ; g-ir-compiler, etc.
+ ("pkg-config" ,pkg-config)))
(synopsis "GNOME text and font handling library")
(description
"Pango is the core text and font handling library used in GNOME