summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-12 10:46:18 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 16:00:33 -0400
commitbe06dea224dd222386725f056980c3999c7ac36d (patch)
tree476e8cac36d8f41ef32c3edd2ecff37450ea4ccf
parent09998230b27b266c053e62f43f6adcf8a1c6e2b8 (diff)
downloadguix-patches-be06dea224dd222386725f056980c3999c7ac36d.tar
guix-patches-be06dea224dd222386725f056980c3999c7ac36d.tar.gz
gnu: json-glib: Update to 1.6.2.
* gnu/packages/gnome.scm (json-glib)[version]: Update to 1.6.2. [arguments]<#:glib-or-gtk?>: New argument. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 50d16a6048..22fd435feb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4552,7 +4552,7 @@ configuration storage systems.")
(define-public json-glib
(package
(name "json-glib")
- (version "1.4.4")
+ (version "1.6.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4560,15 +4560,17 @@ configuration storage systems.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0ixwyis47v5bkx6h8a1iqlw3638cxcv57ivxv4gw2gaig51my33j"))))
+ "092g2dyy1hhl0ix9kp33wcab0pg1qicnsv0cj5ms9g9qs336cgd3"))))
(build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t)) ; To wrap binaries and/or compile schemas
(native-inputs
`(("gettext" ,gettext-minimal)
- ("glib" ,glib "bin") ;for glib-mkenums and glib-genmarshal
+ ("glib" ,glib "bin") ;for glib-mkenums and glib-genmarshal
("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)))
(propagated-inputs
- `(("glib" ,glib))) ;according to json-glib-1.0.pc
+ `(("glib" ,glib))) ;according to json-glib-1.0.pc
(home-page "https://wiki.gnome.org/Projects/JsonGlib")
(synopsis "Compiler for the GObject type system")
(description