summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-08 11:54:51 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-08 12:08:44 -0500
commitbc5904e8b85d4d994861ecd55b038ad42305e77d (patch)
tree9bdb55896863b2b2e9137579c0885b3d135bfc47
parentf9c62b23cc88541756656b3ec602ce987828d906 (diff)
downloadguix-patches-bc5904e8b85d4d994861ecd55b038ad42305e77d.tar
guix-patches-bc5904e8b85d4d994861ecd55b038ad42305e77d.tar.gz
gnu: pict: Use release tag and install doc.
* gnu/packages/check.scm (pict)[origin]: Use the release tag (newly added upstream). [phases]{install}: Also install the pict.md file.
-rw-r--r--gnu/packages/check.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4915a5ec88..06adf20c36 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -99,9 +99,7 @@
(method git-fetch)
(uri (git-reference
(url "https://github.com/Microsoft/pict")
- ;; The tag name for v3.7.2 is odd ("release"); use the
- ;; corresponding commit for now.
- (commit "b10237099713ef0e45f222042cef01dc3507a611")))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
@@ -115,7 +113,10 @@
(delete 'configure)
(replace 'install
(lambda _
- (install-file "pict" (string-append #$output "/bin")))))))
+ (install-file "pict" (string-append #$output "/bin"))
+ (install-file "doc/pict.md"
+ (string-append #$output
+ "/share/doc/pict-" #$version)))))))
(native-inputs (list perl))
(home-page "https://www.pairwise.org/")
(synopsis "Pairwise Independent Combinatorial Tool")