summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJai Vetrivelan <jaivetrivelan@gmail.com>2022-02-02 06:07:39 +0530
committerLudovic Courtès <ludo@gnu.org>2022-02-08 13:34:02 +0100
commit9faeca1f23b841a6f48900f52f0085df51d48119 (patch)
tree5d07047f26d568ecc64facada63f1997abba3109
parent7fbb6fe0e1035e2a09fe9ffcd5b91c1586510f99 (diff)
downloadguix-patches-9faeca1f23b841a6f48900f52f0085df51d48119.tar
guix-patches-9faeca1f23b841a6f48900f52f0085df51d48119.tar.gz
gnu: Add emacs-spray.
* gnu/packages/emacs-xyz.scm: (emacs-spray) new variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 56af72b2ab..9b57b36623 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4529,6 +4529,29 @@ Emacs Lisp. It generates a sparkline string given a list of numbers. It is a
port of @code{cl-spark} to Emacs Lisp.")
(license license:expat))))
+(define-public emacs-spray
+ (let ((version "0.0.2") (revision "0")
+ (commit "74d9dcfa2e8b38f96a43de9ab0eb13364300cb46"))
+ (package
+ (name "emacs-spray")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~iank/spray")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1avbfr32dvff26kgvd5vgan99nb5c6al9kv5xbmy2rcls17py7r2"))))
+ (build-system emacs-build-system)
+ (home-page "https://git.sr.ht/~iank/spray")
+ (synopsis "Speed reading mode for Emacs")
+ (description
+ "For speed reading, or just more enjoyable reading. Narrows
+the buffer to show one word at a time. Adjust speed / pause as needed.")
+ (license license:gpl3+))))
+
(define-public emacs-es-mode
(package
(name "emacs-es-mode")