summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 11:34:48 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:39 -0400
commit87d33d72a0c40d81ed5802ba63ed8b2446d0de50 (patch)
treedcf5f8a0d76e9eb018951914667f04afacc7c81b
parent31ed6339c47f03f382ab91982950302baa15c715 (diff)
downloadguix-patches-87d33d72a0c40d81ed5802ba63ed8b2446d0de50.tar
guix-patches-87d33d72a0c40d81ed5802ba63ed8b2446d0de50.tar.gz
gnu: vala: Update to 0.52.0.
* gnu/packages/gnome.scm (vala) [version]: Update to 0.52.0. [native-inputs]: Add help2man and perl. [inputs]: Move graphviz to ... [propagated-inputs]: ... here. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 92c46158ac..70e3c38e20 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -141,6 +141,7 @@
#:use-module (gnu packages lirc)
#:use-module (gnu packages lua)
#:use-module (gnu packages mail)
+ #:use-module (gnu packages man)
#:use-module (gnu packages mp3)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages music)
@@ -4270,7 +4271,7 @@ passwords in the GNOME keyring.")
(define-public vala
(package
(name "vala")
- (version "0.50.3")
+ (version "0.52.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/vala/"
@@ -4278,7 +4279,7 @@ passwords in the GNOME keyring.")
"vala-" version ".tar.xz"))
(sha256
(base32
- "1nx5xjarpkl9hgy0qbqfczx7d7clh5g1r8xr5xp8b97c5fsc2rb1"))))
+ "12y6p8wdjp01vmfhxg2cgh32xnyqq6ivblvrar9clnj6vc867qhx"))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:configure-flags '("--enable-coverage")
@@ -4300,18 +4301,19 @@ passwords in the GNOME keyring.")
(("export PKG_CONFIG_PATH=" m)
(string-append m "$PKG_CONFIG_PATH:"))))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("bison" ,bison)
+ ("dbus" ,dbus) ; for dbus tests
("docbook-xml" ,docbook-xml-4.4)
("docbook-xsl" ,docbook-xsl)
("flex" ,flex)
- ("bison" ,bison)
- ("xsltproc" ,libxslt)
- ("dbus" ,dbus) ; for dbus tests
- ("gobject-introspection" ,gobject-introspection))) ; for gir tests
- (inputs
- `(("graphviz" ,graphviz)))
+ ("gobject-introspection" ,gobject-introspection) ; for gir tests
+ ("help2man" ,help2man)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("xsltproc" ,libxslt)))
(propagated-inputs
- `(("glib" ,glib))) ; required by libvala-0.40.pc
+ `(("glib" ,glib) ; required by libvala-0.40.pc
+ ("libgvc" ,graphviz)))
(home-page "https://wiki.gnome.org/Projects/Vala/")
(synopsis "Compiler for the GObject type system")
(description