summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:14:54 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:40:20 -0400
commit736c5df29ac380413ec45b496c63dcf80672712d (patch)
treecb83e7fe5faa438b423b1dca72c067d2c768bdbc
parentca81e057b2b6c6b7b3dc8598c84d81d6bbb16512 (diff)
downloadguix-patches-736c5df29ac380413ec45b496c63dcf80672712d.tar
guix-patches-736c5df29ac380413ec45b496c63dcf80672712d.tar.gz
gnu: cairomm-1.13: Fix build.
* gnu/packages/gtk.scm (cairomm-1.13)[build-system]: New field. [arguments]: New field. [propagated-inputs]: Replace libsigc++ with libsigc++-2. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4c3514c2a9..06e7904d3d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1325,9 +1325,22 @@ library.")
name "-" version ".tar.gz"))
(sha256
(base32 "1xlfl0fm5mgv53lr8xjv2kqsk3bz67qkk6qzvbrqmbvbvvbqp9wp"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/doc")
+ (string-append doc "/share/doc"))
+ #t))))))
(propagated-inputs
- `(("cairo" ,cairo)
- ("sigc++" ,libsigc++)))))
+ `(("libsigc++" ,libsigc++-2)
+ ,@(package-propagated-inputs cairomm)))))
(define-public pangomm
(package