summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 13:24:57 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 16:00:33 -0400
commit5e4d1f6c407e145dbf978701e66935157bbacc04 (patch)
tree08f5da2c4d16aaadb1cea244cb7ac455fec166f3
parent34d450272950b1901ae193379ed0be3b146e3b44 (diff)
downloadguix-patches-5e4d1f6c407e145dbf978701e66935157bbacc04.tar
guix-patches-5e4d1f6c407e145dbf978701e66935157bbacc04.tar.gz
gnu: at-spi2-core: Fix documentation.
* gnu/packages/gtk.scm (at-spi2-core) [arguments]<#:phases>['patch-docbook-sgml]: New phase. [native-inputs]: Add docbook-xml. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 7c194a905c..c681c71fb4 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -713,6 +713,14 @@ scaled, composited, modified, saved, or rendered.")
(lambda* (#:key outputs #:allow-other-keys)
(mkdir-p (string-append (assoc-ref outputs "doc") "/share"))
#t))
+ (add-after 'unpack 'patch-docbook-sgml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((xmldoc (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook")))
+ (substitute* "doc/libatspi/libatspi-docs.sgml"
+ (("http://.*/docbookx\\.dtd")
+ (string-append xmldoc "/docbookx.dtd")))
+ #t)))
(add-after 'install 'move-documentation
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -741,7 +749,8 @@ scaled, composited, modified, saved, or rendered.")
("libxi" ,libxi)
("libxtst" ,libxtst)))
(native-inputs
- `(("gettext" ,gettext-minimal)
+ `(("docbook-xml" ,docbook-xml-4.3)
+ ("gettext" ,gettext-minimal)
("glib" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
("gtk-doc" ,gtk-doc)