summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-03-28 12:51:08 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-28 18:46:22 +0200
commit43469e193ba5c2d06c5f3e10d5550ce7ec201729 (patch)
tree6c46cf501e73c2444ba0dcc359b58bda540c1376
parent510e24f973a918391d8122fd6ad515c0567bf23e (diff)
downloadguix-patches-43469e193ba5c2d06c5f3e10d5550ce7ec201729.tar
guix-patches-43469e193ba5c2d06c5f3e10d5550ce7ec201729.tar.gz
gnu: autofs: Update to 5.1.7.
* gnu/packages/file-systems.scm (autofs): Update to 5.1.7. [arguments]: Add a new 'fix-rpath phase.
-rw-r--r--gnu/packages/file-systems.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 198653c639..ae10796fab 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -80,7 +80,7 @@
(define-public autofs
(package
(name "autofs")
- (version "5.1.6")
+ (version "5.1.7")
(source
(origin
(method url-fetch)
@@ -88,7 +88,7 @@
"v" (version-major version) "/"
"autofs-" version ".tar.xz"))
(sha256
- (base32 "1vya21mb4izj3khcr3flibv7xc15vvx2v0rjfk5yd31qnzcy7pnx"))))
+ (base32 "1myfz6a3wj2c4j9h5g44zj796fdi82jhp1s92w2hg6xp2632csx3"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -112,6 +112,12 @@
(("^searchpath=\".*\"")
"searchpath=\"$PATH\""))
#t))
+ (add-before 'configure 'fix-rpath
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile.rules"
+ (("^AUTOFS_LIB_LINK.*=" match)
+ (string-append match " -Wl,-rpath=" out "/lib"))))))
(add-before 'install 'omit-obsolete-lookup_nis.so-link
;; Building lookup_yp.so depends on $(YPCLNT) but this doesn't,
;; leading to a make error. Since it's broken, comment it out.