summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 10:50:46 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:37 -0400
commit37d5790fae0a79e4b5b778c8deb483816199a61e (patch)
tree134faa6e6ef4aa4463ae018f65a23f1e50067e87
parentd244c18eef456cd6cfa4e21cfaebcab595797ab2 (diff)
downloadguix-patches-37d5790fae0a79e4b5b778c8deb483816199a61e.tar
guix-patches-37d5790fae0a79e4b5b778c8deb483816199a61e.tar.gz
gnu: gdk-pixbuf: Fix documentation.
* gnu/packages/gtk.scm (gdk-pixbuf) [arguments]<#:phases>['patch-docbook]: New phase. [native-inputs]: Add docbook-xml and docbook-xsl. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2c1a9e84fc..058b396f67 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -592,10 +592,22 @@ highlighting and other features typical of a source code editor.")
(build-system meson-build-system)
(arguments
`(#:meson ,meson-0.55
- #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:configure-flags '("-Dinstalled_tests=false" "-Djasper=true")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "docs"
+ (substitute* "meson.build"
+ (("http://docbook.sourceforge.net/release/xsl/current/")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-1.79.2/")))
+ (substitute* (find-files "." "\\.xml$")
+ (("http://www.oasis-open.org/docbook/xml/4\\.3/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/"))))
+ #t))
;; The slow tests take longer than the specified timeout.
,@(if (any (cute string=? <> (%current-system))
'("armhf-linux" "aarch64-linux"))
@@ -616,10 +628,12 @@ highlighting and other features typical of a source code editor.")
("libpng" ,libpng)
("libtiff" ,libtiff)))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("docbook-xml" ,docbook-xml-4.3)
+ ("docbook-xsl" ,docbook-xsl)
("gettext" ,gettext-minimal)
("glib" ,glib "bin") ; glib-mkenums, etc.
- ("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
+ ("gobject-introspection" ,gobject-introspection) ; g-ir-compiler, etc.
+ ("pkg-config" ,pkg-config)))
(synopsis "GNOME image loading and manipulation library")
(description
"GdkPixbuf is a library for image loading and manipulation developed